Composer 新建项目报错解决方案

今天我想新建一个项目,于是composer一下模板项目,在虚拟机的 code 文件夹下使用了如下的指令

composer create-project laravel/laravel Laravel --prefer-dist "5.8.*"

但是报错了

错误详情

鼓捣好久后,没啥头绪,我看了看 Laravel 的外文官方文档,说可以不用 composer 下这个模板项目了

官方网站上的文档

这样的话就先试试呗,于是就安装了 Laravel install ,一个专门的安装器

composer global require laravel/installer

然后新建一个叫 blog 的文件夹并把模板文件生成在这里面

laravel new blog

然后就是喜闻乐见的下半天下不下来,墙的非常难受,放弃该方案

再换个思路,code 下的项目虚拟机和本机都是可以访问的,既然虚拟机报错,我本机把项目 composer 下来不也一样么?先自己把本机的 composer 下载安装,上了阿里的源进行加速,试了一下看看行不行

居然行了

问题的原因虽然没解决,但是这个项目下下来了,不影响正常使用,问题暂时解决

我还把这个下下来的项目的 compaser.json 放在没成功下载下来的项目文件夹里,在虚拟机里居然也没问题了,可以下载了,很迷,为啥同样的指令,虚拟机不行本机行。

2019.07.22 问题来了,在本机composer下来的项目浏览器访问报错,好在刚开始,我删除了vm虚拟机的全部虚拟机,重新下8.0.0 的包,一切从头来,然后问题解决了

NightingaleWK

曾经我是一名冒险家,直到我的膝盖中了一箭。

相关推荐

发表评论

电子邮件地址不会被公开。 必填项已用*标注

微信扫一扫

微信扫一扫

微信扫一扫,分享到朋友圈

Composer 新建项目报错解决方案
返回顶部

显示

忘记密码?

显示

显示

获取验证码

Close